Author Topic: Class invisible does not work for ExtendedLog  (Read 1933 times)

Offline blelu

  • New user
  • *
  • Posts: 10
    • View Profile
Class invisible does not work for ExtendedLog
« on: June 24, 2014, 10:13:16 am »
Hello,

I need NOT to log information from some IP adresses, I tried the following howto:
  <Class invisible>
    From 1.2.3.4
  </Class>
  <IfClass invisible>
    # Disable all logging of these clients
    SystemLog none
    ExtendedLog /path/to/ext.log NONE
    TransferLog none
  </IfClass>

But the problem is that nothing is logged at all in the /path/to/ext.log, although information is logged in the TransferLog.

Thanks

Offline castaglia

  • Administrator
  • Support Hero
  • *****
  • Posts: 5253
    • View Profile
    • http://www.castaglia.org/
Re: Class invisible does not work for ExtendedLog
« Reply #1 on: June 24, 2014, 01:52:52 pm »
What version of proftpd are you using?  What does proftpd debug logging, debug level 10, when you connect from the <Class invisible> IP address range?

Offline blelu

  • New user
  • *
  • Posts: 10
    • View Profile
Re: Class invisible does not work for ExtendedLog
« Reply #2 on: June 25, 2014, 08:35:55 am »
Hi,

Well actually it does not for TransferLog too.

I am using ProFTPD Version 1.3.5

In the server config section I have:
<Class invisible>
    From 1.2.3.4
    From 1.2.3.5
    From 1.2.3.6
</Class>

And in the global section I have

<IfClass invisible>
  # Disable all logging of these clients
  ExtendedLog                   /ftp/log/proftpd_debug1.log     NONE
  TransferLog none
</IfClass>

TransferLog                     /ftp/log/proftpd_transfer1.log
ExtendedLog                     /ftp/log/proftpd_debug1.log     ALL     default

What I am expected is to have nothing logged from the invisible class but everything logged for the other addresses. The problem is that everything is logged, I suppose a configuration issue.

If the IfClass directive is in the server config section, nothing is logger.

Thansk and best regards

Bernard

Offline castaglia

  • Administrator
  • Support Hero
  • *****
  • Posts: 5253
    • View Profile
    • http://www.castaglia.org/
Re: Class invisible does not work for ExtendedLog
« Reply #3 on: June 25, 2014, 01:32:08 pm »
So, just to be clear, you have something like:

  <Class invisible>
    From 1.2.3.4
    From 1.2.3.5
    From 1.2.3.6
  </Class>

  <Global>
    <IfClass invisble>
      # Disable logging
      ...
    </IfClass>
  </Global>

I'm not sure how well mod_ifsession currently works with <Global> sections; I'll do some testing.  This could be a bug.

Offline castaglia

  • Administrator
  • Support Hero
  • *****
  • Posts: 5253
    • View Profile
    • http://www.castaglia.org/
Re: Class invisible does not work for ExtendedLog
« Reply #4 on: June 26, 2014, 04:04:33 pm »
Are you seeing the (unexpected) log lines in your ExtendedLog, in the TransferLog, or in both?

Offline blelu

  • New user
  • *
  • Posts: 10
    • View Profile
Re: Class invisible does not work for ExtendedLog
« Reply #5 on: June 27, 2014, 06:00:12 am »
I need to define the logs in the Global section unless I am not logging anything at all.

So in the Global section I have
<IfClass invisible>
  # Disable all logging of these clients
  ExtendedLog                   /ftp/log/proftpd_debug1.log     NONE
  TransferLog none
</IfClass>
TransferLog                     /ftp/log/proftpd_transfer1.log
ExtendedLog                     /ftp/log/proftpd_debug1.log     ALL     default

And everything is logs, the IfClass has no effect.

Offline blelu

  • New user
  • *
  • Posts: 10
    • View Profile
Re: Class invisible does not work for ExtendedLog
« Reply #6 on: August 13, 2014, 12:42:07 pm »
Hello,

Were you able to work on this problem.

Thanks and best regards

 

sighted planning