Author Topic: 451 transfer aborted I/O Error  (Read 5338 times)

Offline michaelh

  • New user
  • *
  • Posts: 16
    • View Profile
451 transfer aborted I/O Error
« on: October 01, 2007, 03:12:22 pm »
hello, i am using proftpd 1.3.0 and am when attempting to ftp a file that is over 1GB receive the following error:

451 Transfer aborted. I/O error
226 Abort successful

I have used both standard windows ftp, filezilla, and a standard UNIX (AIX) ftp client.  It appears that it is always the same size it bombs out on; 1073741312KB.  Proftpd is running on an AIX 5.3 server with home directories on a JFS2 file system, so large file support *should* not be an issue. 

Is there a setting or directive I can add or remove to allow large files?  Has anyone ever seen this before?  Could it be a operating system error rather than proftpd?  Any suggestions?  Thanks

Offline castaglia

  • Administrator
  • Support Hero
  • *****
  • Posts: 4995
    • View Profile
    • http://www.castaglia.org/
Re: 451 transfer aborted I/O Error
« Reply #1 on: October 01, 2007, 04:25:29 pm »
You might try adding the following to your proftpd.conf:

  UseSendfile off

Offline michaelh

  • New user
  • *
  • Posts: 16
    • View Profile
Re: 451 transfer aborted I/O Error
« Reply #2 on: October 01, 2007, 07:00:14 pm »
It appears to be an operating system issue.  even thought large file support is enabled, i had to increase the file size limit in the /etc/security/limits file to unlimited.  i was then able to create a file over 1GB, however i am still unable to ftp a file over 1gb.  i am using authuserfile and authgroupfile directives to authenticate users, and I am wondering if the operating system is not using the new limits becasue the OS doesn't know these users.  I tried the UseSendfile directive and that did not help.  Any other suggestions?   Thanks in advance. 

Offline castaglia

  • Administrator
  • Support Hero
  • *****
  • Posts: 4995
    • View Profile
    • http://www.castaglia.org/
Re: 451 transfer aborted I/O Error
« Reply #3 on: October 01, 2007, 08:51:51 pm »
Could you provide your full proftpd.conf?